import Foundation
let pattern = #"(?<DeviceId>\w*)\s+,\s+(?<Description>[\w\'\-]*[\,\s]?[\w\s]+)\s+,\s+(?<Model>[\w\s\-()]*)\s+,\s+(?<Protocol>[A-Z]+)\s+,\s+(?<DevicePool>[\w\-]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name (constant) descripton (constant) name (constant) name (constant) name
=============== ========== ================ ========== ================================= ========== ==== ========== =======
CSFCOGRADY , O'Grady, Conor CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-AL-DESKTOP
CSFJIWU , Wu, Jiayi CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-FH-DESKTOP
SEPB8621F6D62BB , Auto 2032 , Cisco 8961 , SIP , Default
SEPDC4A3E576074 , Auto 2000 , Cisco IP Communicator , SCCP , Default
SEP00FFF74297DE , Auto 2047 , Cisco IP Communicator , SCCP , Default
SEP001A2B3C0000 , Sip Test Lines A , Third-party SIP Device (Advanced) , SIP , Default
SEP001A2B3C0001 , Sip Test Lines B , Third-party SIP Device (Advanced) , SIP , Default
SEP68ECC5620C0E , Auto 2001 , Cisco IP Communicator , SCCP , Default
SEP8C1645309770 , Auto 2002 , Cisco IP Communicator , SCCP , Default
SEP1C1D862E9E8A , Auto 2022 , Cisco 8961 , SIP , Default
SEP8C1645309837 , Auto 2003 , Cisco IP Communicator , SCCP , Default
SEP8C164530972E , Auto 2004 , Cisco IP Communicator , SCCP , Default
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)