# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<DeviceId>\w*)\s+,\s+(?<Description>[\w\'\-]*[\,\s]?[\w\s]+)\s+,\s+(?<Model>[\w\s\-()]*)\s+,\s+(?<Protocol>[A-Z]+)\s+,\s+(?<DevicePool>[\w\-]*)"
test_str = ("name (constant) descripton (constant) name (constant) name (constant) name \n"
"=============== ========== ================ ========== ================================= ========== ==== ========== ======= \n"
"CSFCOGRADY , O'Grady, Conor CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-AL-DESKTOP\n"
"CSFJIWU , Wu, Jiayi CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-FH-DESKTOP\n\n"
"SEPB8621F6D62BB , Auto 2032 , Cisco 8961 , SIP , Default \n"
"SEPDC4A3E576074 , Auto 2000 , Cisco IP Communicator , SCCP , Default \n"
"SEP00FFF74297DE , Auto 2047 , Cisco IP Communicator , SCCP , Default \n"
"SEP001A2B3C0000 , Sip Test Lines A , Third-party SIP Device (Advanced) , SIP , Default \n"
"SEP001A2B3C0001 , Sip Test Lines B , Third-party SIP Device (Advanced) , SIP , Default \n"
"SEP68ECC5620C0E , Auto 2001 , Cisco IP Communicator , SCCP , Default \n"
"SEP8C1645309770 , Auto 2002 , Cisco IP Communicator , SCCP , Default \n"
"SEP1C1D862E9E8A , Auto 2022 , Cisco 8961 , SIP , Default \n"
"SEP8C1645309837 , Auto 2003 , Cisco IP Communicator , SCCP , Default \n"
"SEP8C164530972E , Auto 2004 , Cisco IP Communicator , SCCP , Default\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.