#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<DeviceId>\w*)\s+,\s+(?<Description>[\w\'\-]*[\,\s]?[\w\s]+)\s+,\s+(?<Model>[\w\s\-()]*)\s+,\s+(?<Protocol>[A-Z]+)\s+,\s+(?<DevicePool>[\w\-]*)"
Local $sString = "name (constant) descripton (constant) name (constant) name (constant) name " & @CRLF & _
"=============== ========== ================ ========== ================================= ========== ==== ========== ======= " & @CRLF & _
"CSFCOGRADY , O'Grady, Conor CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-AL-DESKTOP" & @CRLF & _
"CSFJIWU , Wu, Jiayi CSF , Cisco Unified Client Services Framework , SIP , DP-GBLON-FH-DESKTOP" & @CRLF & _
"" & @CRLF & _
"SEPB8621F6D62BB , Auto 2032 , Cisco 8961 , SIP , Default " & @CRLF & _
"SEPDC4A3E576074 , Auto 2000 , Cisco IP Communicator , SCCP , Default " & @CRLF & _
"SEP00FFF74297DE , Auto 2047 , Cisco IP Communicator , SCCP , Default " & @CRLF & _
"SEP001A2B3C0000 , Sip Test Lines A , Third-party SIP Device (Advanced) , SIP , Default " & @CRLF & _
"SEP001A2B3C0001 , Sip Test Lines B , Third-party SIP Device (Advanced) , SIP , Default " & @CRLF & _
"SEP68ECC5620C0E , Auto 2001 , Cisco IP Communicator , SCCP , Default " & @CRLF & _
"SEP8C1645309770 , Auto 2002 , Cisco IP Communicator , SCCP , Default " & @CRLF & _
"SEP1C1D862E9E8A , Auto 2022 , Cisco 8961 , SIP , Default " & @CRLF & _
"SEP8C1645309837 , Auto 2003 , Cisco IP Communicator , SCCP , Default " & @CRLF & _
"SEP8C164530972E , Auto 2004 , Cisco IP Communicator , SCCP , Default" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")