re = /(?P<le>\[)?(?P<min>\d\d)\]?(?P<adds>[^\s]+)?/m
str = '[02]^mc
[02c^
[02c^
49m^'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end