const regex = new RegExp('(?P<le>\\[)?(?P<min>\\d\\d)\\]?(?P<adds>[^\\s]+)?', 'gm')
const str = `[02]^mc
[02c^
[02c^
49m^`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}