package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<le>\[)?(?P<min>\d\d)\]?(?P<adds>[^\s]+)?`)
var str = `[02]^mc
[02c^
[02c^
49m^`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}