// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z\s\d\/\+\(\)\#\&]*$").unwrap();
let string = "Card Name #1
Card Name (1)
Card Name / 1
Card Name &1
Card_Name + 1
card -sd
Card_Name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}