$re = '/^[a-zA-Z\s\d\/\+\(\)\#\&]*$/m';
$str = 'Card Name #1
Card Name (1)
Card Name / 1
Card Name &1
Card_Name + 1
card -sd
Card_Name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);