package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\s\d\/\+\(\)\#\&]*$`)
var str = `Card Name #1
Card Name (1)
Card Name / 1
Card Name &1
Card_Name + 1
card -sd
Card_Name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}