import Foundation
let pattern = #"^[a-zA-ZA]{4}(\d{8}|\d{5})[a-zA-z]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AAQU00016341M
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}