$re = '/^[a-zA-ZA]{4}(\d{8}|\d{5})[a-zA-z]$/';
$str = 'AAQU00016341M
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);