const regex = /^[a-zA-ZA]{4}(\d{8}|\d{5})[a-zA-z]$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-ZA]{4}(\\d{8}|\\d{5})[a-zA-z]$', '')
const str = `AAQU00016341M
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}