re = /(background:\s*url\((https?:\/\/)*([a-zA-Z0-9._:\/\s*]*)\)\s*[a-zA-Z0-9\s*-._:\/;]*)/
str = '.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(../instant/templates/_default_/images/nyromodal/close.gif);
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end