package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(background:\s*url\((https?:\/\/)*([a-zA-Z0-9._:\/\s*]*)\)\s*[a-zA-Z0-9\s*-._:\/;]*)`)
var str = `.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(../instant/templates/_default_/images/nyromodal/close.gif);
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}