using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(background:\s*url\((https?:\/\/)*([a-zA-Z0-9._:\/\s*]*)\)\s*[a-zA-Z0-9\s*-._:\/;]*)";
string input = @".nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(http://instantcms.ru/templates/_default_/images/nyromodal/close.gif) no-repeat 6px center;
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(https://instant/templates/_default_/images/nyromodal/close.gif);
}
.nyroModalCloseButton {
top: -13px;
right: -13px;
width: 12px;
height: 12px;
text-indent: -9999em;
background: url(../instant/templates/_default_/images/nyromodal/close.gif);
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}