re = /((^090)([23589]))|((^070)([1-9]))|((^080)([2-9]))|((^081)([0-9]))(\d{7})/
str = '08121434763'
# Print the match result
str.match(re) do |match|
puts match.to_s
end