package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((^090)([23589]))|((^070)([1-9]))|((^080)([2-9]))|((^081)([0-9]))(\d{7})`)
var str = `08121434763`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}