using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^090)([23589]))|((^070)([1-9]))|((^080)([2-9]))|((^081)([0-9]))(\d{7})";
string input = @"08121434763";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}