import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#([a-zA-Z0-9-_]+)$";
final String string = "http://blabla.com/test#hashhere\n"
+ "http://blabla.com/test#hashHere\n"
+ "http://blabla.com/test#hash-name\n"
+ "http://blabla.com/test#hash_here\n"
+ "http://blabla.com/test#hash1\n"
+ "http://blabla.com/test#hash_1\n"
+ "http://blabla.com/test#hash-1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}