#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#([a-zA-Z0-9-_]+)$"
Local $sString = "http://blabla.com/test#hashhere" & @CRLF & _
"http://blabla.com/test#hashHere" & @CRLF & _
"http://blabla.com/test#hash-name" & @CRLF & _
"http://blabla.com/test#hash_here" & @CRLF & _
"http://blabla.com/test#hash1" & @CRLF & _
"http://blabla.com/test#hash_1" & @CRLF & _
"http://blabla.com/test#hash-1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")