package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#([a-zA-Z0-9-_]+)$`)
var str = `http://blabla.com/test#hashhere
http://blabla.com/test#hashHere
http://blabla.com/test#hash-name
http://blabla.com/test#hash_here
http://blabla.com/test#hash1
http://blabla.com/test#hash_1
http://blabla.com/test#hash-1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}