import Foundation
let pattern = ##"%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Hello World! My name is %s and I have %+05.3f€"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)