using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})";
string input = @"Hello World! My name is %s and I have %+05.3f€";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}