#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)%(?'flag'[-0+ #]{0,3})(?'minwidth'[0-9]*)(?'comma'\.)?(?'precision'(?('comma')[0-9]*))(?'length'[hlqLjzZt]|ll|hh)?(?'type'[dscuobS%nfeEgGaACDiIOUpXx]{1})"
Local $sString = "Hello World! My name is %s and I have %+05.3f€"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")