const regex = /(([\w]*)(-?)([\w]{0,2})(.apps)(-?)([\w]{0,2})(.[\W\w]*))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([\\w]*)(-?)([\\w]{0,2})(.apps)(-?)([\\w]{0,2})(.[\\W\\w]*))', '')
const str = `somestupidurls-qp.apps-np.blahblah.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}