#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(([\w]*)(-?)([\w]{0,2})(.apps)(-?)([\w]{0,2})(.[\W\w]*))"
Local $sString = "somestupidurls-qp.apps-np.blahblah.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")