package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([\w]*)(-?)([\w]{0,2})(.apps)(-?)([\w]{0,2})(.[\W\w]*))`)
var str = `somestupidurls-qp.apps-np.blahblah.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}