$re = '/^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$/m';
$str = '1111111111
1111111111.00
1111111111,00
1,111,111,111.00
1.111.111.111,00
-1111111111
-1111111111.00
-1111111111,00
-1,111,111,111.00
-1.111.111.111,00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);