import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s)?(\\-)?((((\\d+)|(\\d{1,3})(\\,\\d{3})*)(\\.\\d{2})?)|(((\\d+)|(\\d{1,3})(\\.\\d{3})*)(\\,\\d{2})?))$";
final String string = "1111111111\n"
+ "1111111111.00\n"
+ "1111111111,00\n"
+ "1,111,111,111.00\n"
+ "1.111.111.111,00\n\n"
+ "-1111111111\n"
+ "-1111111111.00\n"
+ "-1111111111,00\n"
+ "-1,111,111,111.00\n"
+ "-1.111.111.111,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}