#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\s)?(\-)?((((\d+)|(\d{1,3})(\,\d{3})*)(\.\d{2})?)|(((\d+)|(\d{1,3})(\.\d{3})*)(\,\d{2})?))$"
Local $sString = "1111111111" & @CRLF & _
"1111111111.00" & @CRLF & _
"1111111111,00" & @CRLF & _
"1,111,111,111.00" & @CRLF & _
"1.111.111.111,00" & @CRLF & _
"" & @CRLF & _
"-1111111111" & @CRLF & _
"-1111111111.00" & @CRLF & _
"-1111111111,00" & @CRLF & _
"-1,111,111,111.00" & @CRLF & _
"-1.111.111.111,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")