$re = '/[^`()]+/';
$str = 'WORKS: select everything except for parentheses:
selected (selected)selected
NOT WORKING: include escaped parentheses in the selection.
It should include \\( these \\) parentheses, because they are escaped.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);