package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^`()]+`)
var str = `WORKS: select everything except for parentheses:
selected (selected)selected
NOT WORKING: include escaped parentheses in the selection.
It should include \( these \) parentheses, because they are escaped.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}