import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^`()]+";
final String string = "WORKS: select everything except for parentheses:\n\n"
+ "selected (selected)selected\n\n"
+ "NOT WORKING: include escaped parentheses in the selection.\n\n"
+ "It should include \\( these \\) parentheses, because they are escaped.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}