import Foundation
let pattern = #"Loadcase -- \d+\s+(.+)\s{6}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15
Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--
Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00
Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00
Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00
Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12
Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12
Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00
Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00
Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width
Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0
Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)