# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Loadcase -- \d+\s+(.+)\s{6}"
test_str = ("Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15\n\n"
"Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--\n\n"
"Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00 \n\n"
"Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00 \n\n"
"Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00 \n\n"
"Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12 \n\n"
"Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12 \n\n"
"Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00 \n\n"
"Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00 \n\n"
"Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width\n\n"
"Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0\n\n"
"Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.