#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Loadcase -- \d+\s+(.+)\s{6}"
Local $sString = "Loadcase -- 1 Dead + Roof Live Dur Factors: 1.15 1.15" & @CRLF & _
"" & @CRLF & _
"Domain Type ------------Name------------ Dir plf-beg plf-end -x-beg-- -x-end-- -y-beg-- -y-end--" & @CRLF & _
"" & @CRLF & _
"Top Dead TCDL Vert 14.00 14.00 -2-00-00 11-00-00 " & @CRLF & _
"" & @CRLF & _
"Top Dead TCDL Vert 14.00 14.00 11-00-00 24-00-00 " & @CRLF & _
"" & @CRLF & _
"Bottom Dead BCDL Vert 20.00 20.00 0 22-00-00 " & @CRLF & _
"" & @CRLF & _
"Attic_BC Dead RoomDL_BC Vert 20.00 20.00 3-06-08 18-02-12 " & @CRLF & _
"" & @CRLF & _
"Attic_TC Dead RoomDL_TC Vert 10.00 10.00 3-09-04 18-02-12 " & @CRLF & _
"" & @CRLF & _
"Top RoofLive TCLL Vert 60.00 60.00 -2-00-00 11-00-00 " & @CRLF & _
"" & @CRLF & _
"Top RoofLive TCLL Vert 60.00 60.00 11-00-00 24-00-00 " & @CRLF & _
"" & @CRLF & _
"Domain Type ------------Name------------ Dir Lbs -x-loc-- -y-loc-- EQ plf EQ width" & @CRLF & _
"" & @CRLF & _
"Bottom Dead SidewallDL Vert 49 3-05-03 07-05 24.5 24.0" & @CRLF & _
"" & @CRLF & _
"Bottom Dead SidewallDL Vert 49 18-04-01 07-03 24.5 24.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")