const regex = /((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):("\w+.*"|\w+(:?\w+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((AND|OR|NOT)( ))?([a-z_A-Z0-9]*):("\\w+.*"|\\w+(:?\\w+))', 'gm')
const str = `homo sapiens AND curationstatus:"Manually curated" AND modellingapproach:"Ordinary differential equation model"
test AND UNIPROT:23456 AND metabolism AND heart AND TAXONOMY:40674 AND curation:"Non curated" AND GO:GO:34212 AND publication:23444 AND modellingapproach:"logical model" AND cancer
modelformat:"SBML" AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606
*:* AND modelformat:"SBML" AND modellingapproach:"Ordinary differential equation model" AND TAXONOMY:9606 AND TAXONOMY:10090
*:* AND disease:"Lung Adenocarcinoma" AND cancer AND tumor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}