re = /([A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+,? [A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+)/m
str = 'Imię i nazwisko: Hubar, Patryk. Data urodzenia: 7 czerwca 1993. Numer telefonu: 123-456-789, Imię i nazwisko: Mickiewicz, Adam. Data urodzenia: 22 stycznia
1877. Numer telefonu: 789 456 123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end