import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+,? [A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+)";
final String string = "Imię i nazwisko: Hubar, Patryk. Data urodzenia: 7 czerwca 1993. Numer telefonu: 123-456-789, Imię i nazwisko: Mickiewicz, Adam. Data urodzenia: 22 stycznia\n"
+ "1877. Numer telefonu: 789 456 123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}