using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+,? [A-ZĄĆĘŁŃÓŚŹŻ][a-ząćęłńóśźż]+)";
string input = @"Imię i nazwisko: Hubar, Patryk. Data urodzenia: 7 czerwca 1993. Numer telefonu: 123-456-789, Imię i nazwisko: Mickiewicz, Adam. Data urodzenia: 22 stycznia
1877. Numer telefonu: 789 456 123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}