import Foundation
let pattern = #"([\+\-]?\d+\.?\d*[\+\-\*\/]?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)