const regex = /([\+\-]?\d+\.?\d*[\+\-\*\/]?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\+\\-]?\\d+\\.?\\d*[\\+\\-\\*\\\/]?)', 'g')
const str = `1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}