re = /([\+\-]?\d+\.?\d*[\+\-\*\/]?)/
str = '1001.111+232323.2221u
-1111.2
1111.222/22222/2
-11111+222.3/4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end