re = /(?:\/)(query=[\w+]+)/
str = 'http://www.foo.com/vanity-segment/query=234+ksjdfh+ksjd/more-vanity'
# Print the match result
str.match(re) do |match|
puts match.to_s
end