$re = '/(?:\/)(query=[\w+]+)/';
$str = 'http://www.foo.com/vanity-segment/query=234+ksjdfh+ksjd/more-vanity';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);