using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/)(query=[\w+]+)";
string input = @"http://www.foo.com/vanity-segment/query=234+ksjdfh+ksjd/more-vanity";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}