// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([ ]{2,})").unwrap();
let string = "Teste Espaço espaço tes9 9 fa9 faf-5fdsa1fdsa544fd8974fd89 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}