using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ ]{2,})";
string input = @"Teste Espaço espaço tes9 9 fa9 faf-5fdsa1fdsa544fd8974fd89 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}