use strict;
my $str = '0001_BL_EC.mat
1_BL_EC.mat
1231_NF_EO.mat
1231_NF_EO_1.mat
S0001_NF_EO_Matrix';
my $regex = qr/(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}