import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<file>(?<subject>\\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\\d)?)(?<ext>\\.\\w{3,4})";
final String string = "0001_BL_EC.mat \n"
+ "1_BL_EC.mat \n\n"
+ "1231_NF_EO.mat \n\n"
+ "1231_NF_EO_1.mat\n\n"
+ "S0001_NF_EO_Matrix";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}